您的位置:首页 > 产品设计 > UI/UE

(HDU)1711 - Number Sequence【KMP】

2017-03-08 22:51 411 查看


Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 24863    Accepted Submission(s): 10530


Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one
K exist, output the smallest one.

 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a
.
The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

 

Sample Output

6
-1

 

KMP算法的入门题目,题意为输入一个原始串和一个模板串,在原始串中找到一个连续的和模板串一样的子串,再输出其开头索引,若没有就输出-1。注意KMP停止的时候索引的位置是匹配后模版串尾端的索引,所以要减去模版串长度后+1。

#include <bits/stdc++.h>

using namespace std;

const int MAXN=1000010;
const int MAXM=10010;
int a[MAXN],b[MAXM],nex[MAXM];
int n,m;

void preKMP()
{
int p=0,q=-1; nex[0]=-1;
while(p<m){
while(q!=-1 && b[p]!=b[q]) q=nex[q];
nex[++p]=++q;
}
}

int KMP()
{
preKMP();
int p=0,q=0;
while(p<n&&q<m){
while(q!=-1 && a[p]!=b[q]) q=nex[q];
p++; q++;
if(q==m) return p-m+1;
}
return -1;
}

int main()
{
int t;
for(scanf("%d",&t);t;t--)
{
scanf("%d %d",&n,&m);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
for(int i=0;i<m;i++)
scanf("%d",&b[i]);
printf("%d\n",KMP());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: