您的位置:首页 > 其它

Problem D: 平面上的点——Point类 (I)

2017-03-08 22:06 363 查看

Problem D: 平面上的点——Point类 (I)

Time Limit: 1 Sec  Memory Limit: 4 MB
Submit: 8105  Solved: 3624

[Submit][Status][Web
Board]

Description

在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定。现在我们封装一个“Point类”来实现平面上的点的操作。

根据“append.cc”,完成Point类的构造方法和show()方法。

接口描述:

Point::show()方法:按输出格式输出Point对象。

Input

输入多行,每行为一组坐标“x,y”,表示点的x坐标和y坐标,x和y的值都在double数据范围内。

Output

输出为多行,每行为一个点,X坐标在前,Y坐标在后,Y坐标前面多输出一个空格。每个坐标的输出精度为最长16位。输出格式见sample。

C语言的输入输出被禁用。

Sample Input

1,23,32,1

Sample Output

Point : (1, 2)Point : (3, 3)Point : (2, 1)Point : (0, 0)

HINT

注意精度控制,C语言的输入输出被禁用。

Append Code

append.cc,

#include <iostream>
#include <algorithm>
#include <iomanip>

using namespace std;

class Point
{
private:
double x,y;
public:
Point(double xx,double yy)
{
x = xx;
y = yy;
}
Point()
{
x=y=0;
}
void show()
{
cout<<setprecision(16)<<"Point"<<" "<<':'<<" "<<'('<<x<<','<<" "<<y<<')'<<endl;
}
};
int main()
{
char c;
double a, b;
Point q;
while(std::cin>>a>>c>>b)
{
Point p(a, b);
p.show();
}
q.show();
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: