您的位置:首页 > Web前端

POJ3253——Fence Repair

2017-03-08 21:41 435 查看
Fence Repair

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 45499 Accepted: 14850
Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤
50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made;
you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will
result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 

Lines 2..N+1: Each line contains a single integer describing the length of a needed plank
Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts
Sample Input
3
8
5
8

Sample Output
34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 

The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into
16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
Source

USACO 2006 November Gold
题意:

将一个木板切割成n块, 长度分别为L1,L2,L3...Ln,未切割之前恰好为长度总和,每次切割需要开销这块木板的长度。如:21切割成5,8,8的话。首先切割为13+8 开销为21,将13切割为5+8 开销为13。总开销为34.现希望使得总开销最小,最小是多少?

解:

21->13+8=》21
21->16+5=》21

13->5+8=》13
16->8+8=》16

一共是34  一共是37

贪心思想。

所以要想开销最小,每次将较大的木板切割出来,这样其实是一颗二叉树。倒着求最大开销,将每次最小的两个数作为一块木板切割得来,这样最后的开销最小。

#include <stdio.h>
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>

#define max 20005

using namespace std;

typedef long long ll;

int n;
int a[max];

int main()
{
while(~scanf("%d",&n))
{
memset(a,0,sizeof(a));
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
}

ll sum=0;
while(n>1)
{
int mii1=0;
int mii2=1;

if(a[mii1]>a[mii2]) swap(mii1,mii2);

for(int i=2;i<n;i++)
{
if(a[i]<a[mii1])
{
mii2=mii1;
mii1=i;
}else if(a[i]<a[mii2]){
mii2=i;
}
}
int temp=a[mii1]+a[mii2];
sum+=temp;
if(mii1==n-1) swap(mii1,mii2);
a[mii1]=temp;
a[mii2]=a[n-1];
n--;
}
printf("%lld\n",sum);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息