您的位置:首页 > 其它

算法提高 学霸的迷宫

2017-03-08 16:54 211 查看
算法提高 学霸的迷宫  

时间限制:1.0s   内存限制:256.0MB
    

问题描述

  学霸抢走了大家的作业,班长为了帮同学们找回作业,决定去找学霸决斗。但学霸为了不要别人打扰,住在一个城堡里,城堡外面是一个二维的格子迷宫,要进城堡必须得先通过迷宫。因为班长还有妹子要陪,磨刀不误砍柴功,他为了节约时间,从线人那里搞到了迷宫的地图,准备提前计算最短的路线。可是他现在正向妹子解释这件事情,于是就委托你帮他找一条最短的路线。

输入格式

  第一行两个整数n, m,为迷宫的长宽。

  接下来n行,每行m个数,数之间没有间隔,为0或1中的一个。0表示这个格子可以通过,1表示不可以。假设你现在已经在迷宫坐标(1,1)的地方,即左上角,迷宫的出口在(n,m)。每次移动时只能向上下左右4个方向移动到另外一个可以通过的格子里,每次移动算一步。数据保证(1,1),(n,m)可以通过。

输出格式

  第一行一个数为需要的最少步数K。

  第二行K个字符,每个字符∈{U,D,L,R},分别表示上下左右。如果有多条长度相同的最短路径,选择在此表示方法下字典序最小的一个。

样例输入

Input Sample 1:

3 3

001

100

110

Input Sample 2:

3 3

000

000

000

样例输出

Output Sample 1:

4

RDRD

Output Sample 2:

4

DDRR

数据规模和约定

  有20%的数据满足:1<=n,m<=10

  有50%的数据满足:1<=n,m<=50

  有100%的数据满足:1<=n,m<=500。

#include <stdio.h>  

#include <stdlib.h>  

#include <string.h> 

#include "iostream"

#include "string"

#include "queue"

#include "algorithm"

typedef long long LL;

using namespace std;

const int maxn = 505;

int mp[maxn][maxn];

char fun[maxn][maxn];

int Next[4][2] = { {1,0},{0,-1},{0,1},{-1,0} };

char X[4] ;

int sum = 0;

struct point

{
int x, y;
int f;

}q[maxn*maxn];

void print1(int p)

{
sum++;
if (p!=0)
{
print1(q[p].f);
}

// if (p != 0)

// printf("%c",fun[q[p].x][q[p].y]);

}

void print(int p)

{
//sum++;
if (p != 0)
{
print(q[p].f);
}
if (p != 0)
printf("%c", fun[q[p].x][q[p].y]);

}

int main()

{
memset(mp, 0, sizeof(mp));
strcat(X, "DLRU");
int M, n;
cin >> M >> n;
for (int i = 0; i < M; i++)//输入
{
getchar();
for (int j = 0; j < n; j++)
{
char m = getchar();
if (m != '0')mp[i][j] = 1;
else mp[i][j] = 2;
}

}
point m ;
m.x = 0;
m.y = 0;
m.f = -1;
mp[0][0] = 1;

q[0] = m;

int head=0, tail=1;
while (head<=tail)
{
if (q[head].x == M-1&&q[head].y == n-1)
{
print1(head);
cout << sum-1 << endl;
print(head);
cout << endl;
}
int x = q[head].x;
int y = q[head].y;
for (int i = 0; i < 4; i++)
{
int x1 = x + Next[i][0];
int y1 = y + Next[i][1];
if ((x1 >= 0) && (y1 >= 0 )&& (x1 < M)&&(y1 < n)&&(mp[x1][y1] == 2))
{
fun[x1][y1] = X[i];
mp[x1][y1] = 1;
q[tail].x = x1;
q[tail].y = y1;
q[tail].f = head;
tail++;
}
}
head++;
}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: