您的位置:首页 > 其它

HDU2795:Billboard(线段树)

2017-03-08 15:15 274 查看


Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 20957    Accepted Submission(s): 8670


Problem Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu,
and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

 

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

 

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard,
output "-1" for this announcement.

 

Sample Input

3 5 5
2
4
3
3
3

 

Sample Output

1
2
1
3
-1

 

Author

hhanger@zju

 

Source

HDOJ 2009 Summer Exercise(5)
题意:有块h*w的木板,有n张1*w[i]的纸,要求每张纸按顺序尽量往上往左贴到木板上,问每张纸贴在第几行。

思路:线段树,每个节点记录它儿子的最大空位。

# include <stdio.h>
# include <string.h>
# include <algorithm>
# define MAXN 200000
# define lson l, m, id<<1
# define rson m+1, r, id<<1|1
using namespace std;

int maxv[MAXN<<2], h, w, n, x;
void init(int l, int r, int id)
{
maxv[id] = w;
if(l == r)
return;
int m = (l+r)>>1;
init(lson);
init(rson);
}

int query(int num, int l, int r, int id)
{
if(l == r)
{
maxv[id] -= num;
return l;
}
int m = (l+r)>>1, pos;
if(maxv[id<<1] >= num)
pos = query(num, lson);
else
pos = query(num, rson);
maxv[id] = max(maxv[id<<1], maxv[id<<1|1]);
return pos;
}

int main()
{
while(~scanf("%d%d%d",&h,&w,&n))
{
h = min(h, n);
init(1, h, 1);
while(n--)
{
scanf("%d",&x);
if(x > maxv[1])
puts("-1");
else
printf("%d\n",query(x, 1, h, 1));
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: