您的位置:首页 > 其它

蝴蝶效应 sdutacm

2017-03-07 20:17 288 查看


蝴蝶效应

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic Discuss


Problem Description

蝴蝶效应是气象学家洛伦兹1963年提出来的。其大意为:一只南美洲亚马孙河流域热带雨林中的蝴蝶,偶尔扇动几下翅膀,可能在两周后引起美国德克萨斯引起一场龙卷风。其原因在于:蝴蝶翅膀的运动,导致其身边的空气系统发生变化,并引起微弱气流的产生,而微弱气流的产生又会引起它四周空气或其他系统产生相应的变化,由此引起连锁反应,最终导致其他系统的极大变化。此效应说明,事物发展的结果,对初始条件具有极为敏感的依赖性,初始条件的极小偏差,将会引起结果的极大差异。
我们将问题简化为方程 f(x) = (a*f(max(0,x-b)) + c*f(max(0,x-d)))%1000000007。
现在给出不同的f(0)和n以及参数a,b,c,d,计算出f(n)。


Input

多组输入。
对于每组数据,有六个个整数n,f0(1 <= n <= 10000,1 <= f0 <= 10000),a,b,c,d(1 <= a,b,c,d <= 10000)。


Output

对于每组数据输出f(n)。


Example Input

1 2 3 4 5 6



Example Output

16



Hint

 

Author

import java.util.*;
public class Main {
static int a, b, c, d;
static long f[] = new long[110000];
final static long mod = 1000000007;

public static void main(String[] args) {
long p;
int n;
Scanner cin = new Scanner(System.in);
while(cin.hasNext()){
for(int i = 0; i <= 100010; i++)
f[i] = 0;
n = cin.nextInt();
p = cin.nextLong();
a = cin.nextInt();
b = cin.nextInt();
c = cin.nextInt();
d = cin.nextInt();
f[0] = p;
long x = fou(n);
System.out.println(x);
}
}
public static long fou(int x){
if(x <= 0)
return f[0];
if(f[x] != 0)
return f[x];
f[x] = (a * fou(x - b) + c * fou( x - d)) % mod;
return f[x];
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: