您的位置:首页 > 其它

pat 甲1126. Eulerian Path (欧拉图的判定)

2017-03-07 19:14 423 查看


1126. Eulerian Path (25)

时间限制

300 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven
Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths
start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)
Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (<= 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of
the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either "Eulerian", "Semi-Eulerian", or "Non-Eulerian". Note that all the numbers in the
first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.
Sample Input 1:
7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:
2 4 4 4 4 4 2
Eulerian

Sample Input 2:
6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:
2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:
5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:
3 3 4 3 3
Non-Eulerian

tips:如果联通分量大于1,一定是非欧拉回路。否则0个奇度定点为欧拉回路,两个为半欧拉回路,其余为非欧拉回路

#include<iostream>
using namespace std;

int n,m;
int g[510][511];
int book[510];
int num,cnt;
int in[510];
void dfs(int x)
{
book[x]=1;
for(int i=1;i<=n;i++)
{
if(!book[i]&&g[x][i])dfs(i);
}

}
int main()
{
cin>>n>>m;
for(int i=1;i<=m;i++)
{
int x,y;cin>>x>>y;
if(g[x][y])continue;
g[x][y]=1;g[y][x]=1;
in[x]++;in[y]++;
}
for(int i=1;i<=n;i++)
{
if(i==1)cout<<in[i];else cout<<" "<<in[i];
if(!book[i])dfs(i),num++;
if(in[i]&1)cnt++;
}

putchar(10);

if((num==1&&cnt==2))cout<<"Semi-Eulerian"<<endl;
else if(num==1&&!cnt)cout<<"Eulerian"<<endl;
else cout<<"Non-Eulerian"<<endl;

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: