您的位置:首页 > 其它

POJ2349 Arctic Network(最小生成树,Kruskal)

2017-03-07 19:05 351 查看
题目:

Arctic Network

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 18625 Accepted: 5892
Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will
in addition have a satellite channel. 

Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers.
Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in
km (coordinates are integers between 0 and 10,000).
Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input
1
2 4
0 100
0 300
0 600
150 750

Sample Output
212.13

Source

Waterloo local 2002.09.28
[Submit]   [Go Back]   [Status]  
[Discuss]
思路(借别人的题解);

题意:有S颗卫星和P个哨所,有卫星的两个哨所之间可以任意通信;否则,一个哨所只能和距离它小于等于D的哨所通信。给出卫星的数量和P个哨所的坐标,求D的最小值。

分析:这是一个最小生成树问题。P个哨所最多用P-1条边即可连起来,而S颗卫星可以代替S-1条边,基于贪心思想,代替的边越长,求得的D就越小。所以可以用一个数组保存加入最小生成树的边的长度,共有P-1条边,把前S-1条较长的边代替掉,剩下的边中最长的即为所求,即d[(P-1) - (S-1) - 1] = d[P-S-1]。
代码:

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <string>
#include <iostream>
#include <stack>
#include <queue>
#include <vector>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define N 20000+20
#define M 500000+20
#define MOD 1000000000+7
#define inf 0x3f3f3f3f
using namespace std;
int m,k;
int pre
;
double ans[550];
struct node
{
int u,v;
double w;
} G[M];
struct node1
{
double x,y;
} zz[M];
bool cmp(node a,node b)
{
return a.w<b.w;
}
void init(int n)
{
for(int i=1; i<=n; i++)
pre[i]=i;
}
int find(int x)
{
if(x==pre[x])
return x;
else
{
pre[x]=find(pre[x]);
return pre[x];
}
}
int mix(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx!=fy)
{
pre[fy]=fx;
return 1;
}
return 0;
}
double dist(double x1, double y1, double x2, double y2)
{
return sqrt((x1-x2)*(x1-x2) + (y1-y2)*(y1-y2));
}
void Kruskal(int n)
{
k=0;
for(int i=0; i<m; i++)
if(mix(G[i].u,G[i].v))
{
ans[k++]=G[i].w;

if(k==n-1)
break;
}
}
int main()
{
int t,s,p;
double x,y;
scanf("%d",&t);
while(t--)
{
m=0;
scanf("%d%d",&s,&p);
init(p);
for(int i=1; i<=p; i++)
scanf("%lf%lf",&zz[i].x,&zz[i].y);
for(int i=1; i<=p; i++)
for(int j=i+1; j<=p; j++)
{
G[m].u=i;
G[m].v=j;
G[m++].w=dist(zz[i].x,zz[i].y,zz[j].x,zz[j].y);
G[m].u=j;
G[m].v=i;
G[m++].w=dist(zz[i].x,zz[i].y,zz[j].x,zz[j].y);
}
sort(G,G+m,cmp);
Kruskal(p);
printf("%.2lf\n",ans[p-s-1]);
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: