您的位置:首页 > 编程语言 > C语言/C++

sdutacm-树结构练习——排序二叉树的中序遍历

2017-03-06 23:43 190 查看
树结构练习——排序二叉树的中序遍历
TimeLimit: 1000MS Memory Limit: 65536KB

SubmitStatistic
Problem Description
在树结构中,有一种特殊的二叉树叫做排序二叉树,直观的理解就是——(1).每个节点中包含有一个关键值 (2).任意一个节点的左子树(如果存在的话)的关键值小于该节点的关键值
(3).任意一个节点的右子树(如果存在的话)的关键值大于该节点的关键值。现给定一组数据,请你对这组数据按给定顺序建立一棵排序二叉树,并输出其中序遍历的结果。
 
Input
输入包含多组数据,每组数据格式如下。
第一行包含一个整数n,为关键值的个数,关键值用整数表示。(n<=1000)
第二行包含n个整数,保证每个整数在int范围之内。
Output
为给定的数据建立排序二叉树,并输出其中序遍历结果,每个输出占一行。
 
Example Input

1
2
2
1 20

Example Output

2
1 20

Hint
 

Author
 赵利强
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
#include<math.h>
#include<queue>
#include<stdlib.h>
using namespace std;
typedef struct node
{
int data;
struct node *l;
struct node *r;
}tree;
void insert(tree*&root,int x)
{
if(root == NULL)
{

tree*p;
p = (tree*)malloc(sizeof(tree));
p->data = x;
p->l = NULL;
p->r = NULL;
root =  p;
}
else if(x<root->data)
{
insert(root->l,x);
}
else
{
insert(root->r,x);
}
}
tree* build(tree*root,int a[],int o)
{
root = NULL;
for(int i= 0;i< o;i++)
{
insert(root,a[i]);
}
return root;

}
int top;//控制空格输出
void inout(tree*root)
{
if(root)
{

inout(root->l);
if(top)top=0;
else printf(" ");
printf("%d",root->data);
inout(root->r);

}

}
int main()
{
int n;
while(~scanf("%d",&n))
{
top = 1;
int a[1002],i;
for(i=0;i<n;i++)
scanf("%d",&a[i]);

tree *root;
root = build(root,a,n);
inout(root);
cout<<endl;

}
return 0;

}

/***************************************************
User name: jk160505徐红博
Result: Accepted
Take time: 0ms
Take Memory: 168KB
Submit time: 2017-02-08 09:01:43
****************************************************/


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm sdut c语言 算法