您的位置:首页 > 其它

中国剩余定理(非互质)hdu3579 Hello Kiki ====注意刚好全部整除的情况

2017-03-06 20:43 330 查看


Hello Kiki

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3578    Accepted Submission(s): 1334


Problem Description

One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing "门前大桥下游过一群鸭,快来快来 数一数,二四六七八". And then the cashier put the counted coins back morosely and count again...

Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number
of the remaining coins Ai on her note.

One day Kiki's father found her note and he wanted to know how much coins Kiki was counting.

 

Input

The first line is T indicating the number of test cases.

Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line.

All numbers in the input and output are integers.

1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi

 

Output

For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1.

 

Sample Input

2
2
14 57
5 56
5
19 54 40 24 80
11 2 36 20 76

 

Sample Output

Case 1: 341
Case 2: 5996
#include<cstdio>
#include<iostream>
using namespace std;
#define ll long long
ll g;
void exgcd(ll a,ll b,ll& x,ll& y){
if(b==0){
g=a;
x=1;
y=0;
}
else{
exgcd(b,a%b,y,x);
y-=x*(a/b);
}
}
int main(){
ll n,a,m,mm[10],aa[10],k1,k2,c,T;
cin>>T;
for(int i=1;i<=T;i++){
int flag=1;
cin>>n;
for(int i=1;i<=n;i++)
cin>>mm[i];
for(int i=1;i<=n;i++)
cin>>aa[i];
cout<<"Case "<<i<<": ";
a=aa[1];
m=mm[1];
//m*k1+a=m[i]*k2+a[i]
for(int i=2;i<=n;i++){
c=aa[i]-a;
exgcd(m,mm[i],k1,k2);
if(c%g){
flag=0;
cout<<-1<<endl;
break;
}
k1=k1*c/g;
k1=(k1+mm[i]/g)%(mm[i]/g);
a=k1*m+a;
m=m*mm[i]/g;
}
if(flag)
{
a=(a+m)%m;
if(a)
cout<<a<<endl;
else
cout<<m<<endl;
}
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: