您的位置:首页 > 其它

POJ 3268 Silver Cow Party 最短路

2017-03-06 15:21 525 查看
Silver Cow Party

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 20726 Accepted: 9487
Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional
(one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X 

Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi,
requiring Ti time units to traverse.
Output

Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output
10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
Source

USACO 2007 February Silver
ac代码:
#include <stdio.h>
#include <iostream>
#include <algorithm>
#define INF 0x3f3f3f3f

using namespace std;
int n,m,x,map[1005][1005];
int vis[1005],dis[1005],bf[1005];

int max(int x,int y)
{
return x>y?x:y;
}

void dij()
{
int i,j,min,p;

for(i=1;i<=n;i++)
{
dis[i]=map[x][i];
vis[i]=0;
}

vis[x]=1;

for(i=1;i<=n;i++)
{
min=INF;
for(j=1;j<=n;j++)
{
if(!vis[j]&&dis[j]<min)
{
p=j;
min=dis[j];
}
}
vis[p]=1;
for(j=1;j<=n;j++)
{
if(!vis[j]&&dis[j]>dis[p]+map[p][j])
dis[j]=dis[p]+map[p][j];
}
}

}

int main()
{
int i,j,p,q,t,k,ans;

while(~scanf("%d%d%d",&n,&m,&x))
{
for(i=0;i<=n;i++)
{
for(j=0;j<=n;j++)
{
map[i][j]=INF;
}
}
for(i=0;i<m;i++)
{
scanf("%d%d%d",&p,&q,&t);
if(map[p][q] > t)
map[p][q] = t;
}
dij();
for(i=1;i<=n;i++)
{
bf[i]=dis[i];
// printf("%d ",bf[i]);
}
for(i=1;i<=n;i++)
{
for(j=i+1;j<=n;j++)
{
int tmp;
tmp=map[j][i];
map[j][i]=map[i][j];
map[i][j]=tmp;
}
}
dij();
ans=-1;
for(i=1;i<=n;i++)
{
if(i!=x)
ans=max(bf[i]+dis[i],ans);
}
printf("%d\n",ans);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: