您的位置:首页 > 编程语言 > C语言/C++

sdutacm-求二叉树的层次遍历

2017-03-06 13:00 363 查看
求二叉树的层次遍历
TimeLimit: 1000MS Memory Limit: 65536KB

SubmitStatistic
Problem Description
已知一颗二叉树的前序遍历和中序遍历,求二叉树的层次遍历。
Input
输入数据有多组,输入T,代表有T组测试数据。每组数据有两个长度小于50的字符串,第一个字符串为前序遍历,第二个为中序遍历。
Output
每组输出这颗二叉树的层次遍历。
Example Input

2
abc
bac
abdec
dbeac

Example Output

abc
abcde

Hint
 

Author
fmh

#include<string.h>
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
#include<iostream>
using namespace std;
typedef struct node
{
char data;
struct node*l;
struct node*r;
}tree;
void huifu(char *zhong,char *hou,int len)
{
if(len==0)
return ;
tree *p = new tree;
p->data = *(hou+len-1);
int i = 0;
for(;i<len;i++)
if(zhong[i]==*(hou+len-1))
{
break;
}
cout<<p->data;
huifu(zhong,hou,i);
huifu(zhong+i+1,hou+i,len-i-1);

return ;

}
tree* huifu2(char *xian,char *zhong,int len)
{
tree*head =new tree;
if(len==0)
return NULL;

head->data = *(xian);
int i = 0;
for(;i<len;i++)
{
if(zhong[i]==*xian)
break;

}
head->l = huifu2(xian+1,zhong,i);
head->r = huifu2(xian+i+1,zhong+i+1,len-i-1);
return head;

}
void ccout(tree*root)
{
queue<tree*>q;
tree*p =NULL;
if(root)
{
q.push(root);
}
while(!q.empty())
{
p = q.front();
q.pop();
cout<<p->data;
if(p->l)
{
q.push(p->l);
}
if(p->r)
{

q.push(p->r);
}

}

}
int main()
{

char hou[102],zhong[102],xian[102];
int o;
cin>>o;

while(o--)
{

int len;
scanf("%s%s",xian,zhong);
len = strlen(zhong);
tree* root;
root = huifu2(xian,zhong,len);
ccout(root);
cout<<endl;

}

}

/***************************************************
User name: jk160505徐红博
Result: Accepted
Take time: 0ms
Take Memory: 164KB
Submit time: 2017-02-07 15:42:24
****************************************************/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm sdut c语言 算法