您的位置:首页 > 理论基础 > 数据结构算法

sdutacm-数据结构上机测试4.1:二叉树的遍历与应用1

2017-03-06 12:56 549 查看
数据结构上机测试4.1:二叉树的遍历与应用1
TimeLimit: 1000MS Memory Limit: 65536KB

SubmitStatistic
Problem Description
输入二叉树的先序遍历序列和中序遍历序列,输出该二叉树的后序遍历序列。
Input
第一行输入二叉树的先序遍历序列;
第二行输入二叉树的中序遍历序列。
Output
输出该二叉树的后序遍历序列。
Example Input

ABDCEF
BDAECF

Example Output

DBEFCA

Hint
Author
#include<string.h>
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
#include<iostream>
using namespace std;
typedef struct node
{
char data;
struct node*l;
struct node*r;
}tree;
void huifu(char *xian,char *zhong,int len)
{
if(len==0)
return ;
tree *p = new tree;
p->data = *xian;
int i = 0;
for(;i<len;i++)
if(zhong[i]==*xian)
{
break;
}
huifu(xian+1,zhong,i);
huifu(xian+i+1,zhong+i+1,len-i-1);
cout<<p->data;
return ;

}
int main()
{

char xian[102],zhong[102];
int i,len;
scanf("%s%s",xian,zhong);
len = strlen(xian);
huifu(xian,zhong,len);
cout<<endl;

}

/***************************************************
User name: jk160505徐红博
Result: Accepted
Take time: 0ms
Take Memory: 152KB
Submit time: 2017-02-07 15:04:24
****************************************************/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm sdut c语言 算法