您的位置:首页 > 其它

POJ1308 Is It A Tree?(树,并查集)

2017-03-06 12:30 344 查看
题目:

Is It A Tree?

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 31499 Accepted: 10699
Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers;
the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output
Case 1 is a
4000
tree.
Case 2 is a tree.
Case 3 is not a tree.

Source

North Central North America 1997
[Submit]   [Go Back]   [Status]  
[Discuss]
思路:
题目给了很多数据,问是不是一棵树。

要注意,0 0也是树(空树也是树),树的根节点只有一个

关于树:http://www.riba2534.ren/?p=63

代码:

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <string>
#include <iostream>
#include <stack>
#include <queue>
#include <vector>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define N 500+20
#define M 30000+20
#define MOD 1000000000+7
#define inf 0x3f3f3f3f
using namespace std;
int f[M],vis[M],n,m,flag;

void init()
{
flag=0;
for(int i=1; i<=M; i++)
f[i]=i,vis[i]=0;
}
int find(int x)
{
if(x==f[x])
return x;
else
{
f[x]=find(f[x]);
return f[x];
}
}
void mix(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx!=fy)
f[fy]=fx;
else
flag=1;
}
int main()
{
int x,y,k=1;
while(~scanf("%d%d",&x,&y))
{
if(x<0&&y<0)
return 0;
if(!x||!y)//空树也是树
{
printf("Case %d is a tree.\n",k++);
continue;
}
init();//初始化并查集
mix(x,y);//把x,y加入并查集
vis[x]=1,vis[y]=1;
int a,b;
while(1)
{
scanf("%d%d",&a,&b);
if(a==0&&b==0)
break;
mix(a,b);
vis[a]=1,vis[b]=1;
}
int cnt=0;
//判断是否只有一个根节点
for(int i=1; i<=M; i++)
if(vis[i]&&find(i)==i)
cnt++;
if(cnt>1)
flag=1;
if(flag)
printf("Case %d is not a tree.\n",k++);
else
printf("Case %d is a tree.\n",k++);

}
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: