您的位置:首页 > 其它

POJ1611 The Suspects(并查集)

2017-03-06 11:04 246 查看
题目:

The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 36168 Accepted: 17580
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 

Once a member in a group is a suspect, all members in the group are suspects. 

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1

Source

Asia Kaohsiung 2003
[Submit]   [Go Back]   [Status]  
[Discuss]
思路:
给了n个学生,然后是m行数据,每行数据的第一个数字表示有几个人。学生0感染了非典,然后他的兴趣小组里的所有人也会感染非典,他所在小组里面的其他成员如果参加了其他的社团,那么也会感染非典,m就是小组的组数,问最后有多少个感染了的,简单并查集就不写注释了

代码:

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <string>
#include <iostream>
#include <stack>
#include <queue>
#include <vector>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define N 500+20
#define M 30000+20
#define MOD 1000000000+7
#define inf 0x3f3f3f3f
using namespace std;
int n,m;
int f[M];
void init()
{
for(int i=0; i<n; i++)
f[i]=i;
}
int find(int x)
{
if(x==f[x])
return x;
else
{
f[x]=find(f[x]);
return f[x];
}
}
void mix(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx!=fy)
f[fy]=fx;
}
int main()
{
while(~scanf("%d%d",&n,&m)&&(m||n))
{
init();
int k,a,b;
for(int i=0; i<m; i++)
{
scanf("%d",&k);
if(k==0)continue;
scanf("%d",&a);
for(int j=1; j<k; j++)
{
scanf("%d",&b);
mix(a,b);
}
}
a=find(0);
int sum=1;
for(int i=1; i<n; i++)
if(a==find(i))
sum++;
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: