您的位置:首页 > 其它

师--链表的结点插入

2017-03-05 18:21 302 查看

师--链表的结点插入

[align=center]Time Limit: 1000MSMemory Limit: 65536KB[/align]
[align=center][/align]

Problem Description

给出一个只有头指针的链表和 n 次操作,每次操作为在链表的第 m 个元素后面插入一个新元素x。若m 大于链表的元素总数则将x放在链表的最后。

Input

多组输入。每组数据首先输入一个整数n(n∈[1,100]),代表有n次操作。
接下来的n行,每行有两个整数Mi(Mi∈[0,10000]),Xi。

Output

对于每组数据。从前到后输出链表的所有元素,两个元素之间用空格隔开。

Example Input

4
1 1
1 2
0 3
100 4


Example Output

3 1 2 4


Hint

代码如下:

#include <stdio.h>
#include <stdlib.h>
struct node
{
int data;
struct node *next;
};
struct node* Creat(int m, int x,struct node *head)
{
struct node *p = (struct node *)malloc(sizeof(struct node));
p->data = x;
p->next = NULL;
struct node *q = head->next;
struct node *tail = head;
while(m-- && q)
{
q = q->next;
tail = tail->next;
}
if(m)
{
tail->next = p;
p->next = q;
}
else
{
tail ->next = p;
p->next = NULL;
}
return head;
}
void Show(struct node *head)
{
struct node *p;
p=head->next;
while(p)
{
if(p->next)
printf("%d ",p->data);
else
printf("%d\n",p->data);
p=p->next;
}
}
int main()
{
int n;
int m, x;
while(scanf("%d",&n)!=EOF)
{
struct node *head = (struct node *)malloc(sizeof(struct node));
head->next = NULL;
while(n--)
{
scanf("%d%d",&m,&x);
head = Creat(m,x,head);
}
Show(head);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐