您的位置:首页 > 其它

hdu4939(动态规划)

2017-03-05 14:14 169 查看
/*
Stupid Tower Defense
Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2187    Accepted Submission(s): 603

Problem Description
FSF is addicted to a stupid tower defense game. The goal of tower defense games is to try to stop enemies from crossing a map by building traps to slow them down and towers which shoot at them as they pass.

The map is a line, which has n unit length. We can build only one tower on each unit length. The enemy takes t seconds on each unit length. And there are 3 kinds of tower in this game: The red tower, the green tower and the blue tower.

The red tower damage on the enemy x points per second when he passes through the tower.

The green tower damage on the enemy y points per second after he passes through the tower.

The blue tower let the enemy go slower than before (that is, the enemy takes more z second to pass an unit length, also, after he passes through the tower.)

Of course, if you are already pass through m green towers, you should have got m*y damage per second. The same, if you are already pass through k blue towers, the enemy should have took t + k*z seconds every unit length.

FSF now wants to know the maximum damage the enemy can get.

Input
There are multiply test cases.

The first line contains an integer T (T<=100), indicates the number of cases.

Each test only contain 5 integers n, x, y, z, t (2<=n<=1500,0<=x, y, z<=60000,1<=t<=3)

Output
For each case, you should output "Case #C: " first, where C indicates the case number and counts from 1. Then output the answer. For each test only one line which have one integer, the answer to this question.

Sample Input
1
2 4 3 2 1

Sample Output
Case #1: 12

HintFor the first sample, the first tower is blue tower, and the second is red tower. So, the total damage is 4*(1+2)=12 damage points.

//关键在于确定状态,通过最后一个格子区分状态,确保涵盖所有状态
*/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1507;
typedef long long LL;
LL Dp[maxn][maxn];
int main()
{
int T;
cin >> T;
for (int k = 1; k <= T; k++)
{
LL n, x, y, z, t;
cin >> n >> x >> y >> z >> t;
LL ans = (x*n*t);
memset(Dp, 0, sizeof(Dp));
for (int i = 1; i <= n; i++)
{
for (int j = 0; j <= i; j++)
{
if (j == 0)
{
Dp[i][j] = Dp[i - 1][j] + (i - 1)*y*t;
}
else
{//从对于一个n个格子的情况可以分为两种情况,一种是最后一个格子是绿的,一种是最后一个格子是蓝的
Dp[i][j] = max(Dp[i - 1][j] + (t + z*j)*y*max((i - j - 1), 0), Dp[i - 1][j - 1] + ((j - 1)*z + t)*y*(i - j));
}
ans = max(ans, (long long)(Dp[i][j] + (n - i)*(x + y*(i - j))*(t + j*z)));
}
}
printf("Case #%d: %I64d\n", k, ans);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: