您的位置:首页 > 其它

【HDU 1541】Stars(树状数组)

2017-03-05 12:24 567 查看


Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9286    Accepted Submission(s): 3704


[align=left]Problem Description[/align]
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given
star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
 

[align=left]Input[/align]
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one
point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

[align=left]Output[/align]
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

[align=left]Sample Input[/align]

5
1 1
5 1
7 1
3 3
5 5

 

[align=left]Sample Output[/align]

1
2
1
1
0

 
题目大意:输入星星的坐标,求每个星星坐下方有多少个,按个数输出结果
思路:输入的坐标是按顺序的,只要求出比当前横坐标小的共有多少个就行了。按横坐标建立树状数组,依次求和。注意下标是从0开始,需要加1,树状数组下标为0会T。
           初学树状数组,真是一个神奇的方法。这是第一个用树状数组写的题 hahaha。

#include<bits/stdc++.h>
#define manx 33000
using namespace std;
int n;
int c[manx];
int lowbit(int x)
{
return x&(-x);
}
void add(int x,int num)
{
while(x<=32001){  //注意不是n
c[x]+=num;
x+=lowbit(x);
}
}
int Sum(int x)
{
int sum=0;
while(x){
sum+=c[x];
x-=lowbit(x);
}
return sum;
}
int main()
{
int x,y;
int a[manx];
while(~scanf("%d",&n)){
memset(c,0,sizeof(c));
memset(a,0,sizeof(a));
for (int i=1; i<=n; i++){
scanf("%d%d",&x,&y);
int sum=Sum(x+1);
a[sum]++;
add(x+1,1);  //下标不为0
}
for (int i=0; i<n; i++)
printf("%d\n",a[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: