您的位置:首页 > 其它

PAT A1024. Palindromic Number (25)

2017-03-05 00:00 288 查看

1024. Palindromic Number (25)

https://www.patest.cn/contests/pat-a-practise/1024

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3


#include <iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
using namespace std;
char s[100], tmp[100];

void add() {
int len = strlen(s);
for (int i = 0; i < len; i++)
tmp[len - i - 1] = s[i];
int digit = 0;
for (int i = 0; i < len; i++) {
int t = s[i] + tmp[i] - 2 * '0' + digit;
s[i] = t % 10 + '0';
digit = t / 10;
}
if (digit) {
s[len] = digit + '0';
s[len + 1] = 0;
}
}

//是回文返回1
int judge() {
int len = strlen(s);
if (len == 1) return 1;
for (int i = 0; i < len / 2; i++) {
if (s[i] != s[len - i - 1])
return 0;
}
return 1;
}
int main(int argc, char *argv[]) {
int n;
scanf("%s%d", s, &n);
int len = strlen(s);

reverse(s, s + len);
int i;
for (i = 0; i < n; i++) {
if (judge()) {
break;
}
add();
}
len = strlen(s);
reverse(s, s + len);
printf("%s\n%d\n", s, i);
return 0;
}


#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
string s;
void add() {
string t = s;
reverse(t.begin(), t.end());
int len = s.length(), carry = 0;
for(int i = 0; i < len; i++) {
s[i] = s[i] + t[i] + carry - '0';
carry = 0;
if(s[i] > '9') {
s[i] = s[i] - 10;
carry = 1;
}
}
if(carry) s += '1';
reverse(s.begin(), s.end());
}
int main() {
int cnt;
cin >> s >> cnt;
for(int i = 0; i <= cnt; i++) {
string t = s;
reverse(t.begin(), t.end());
if(s == t) {
cout << s << endl << i;
return 0;
}

3ff0
if(i != cnt) add();
}
cout << s << endl << cnt;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: