您的位置:首页 > 其它

PAT (Advanced Level) Practise 1126 Eulerian Path (25)

2017-03-04 19:21 417 查看


1126. Eulerian Path (25)

时间限制

300 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven
Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths
start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)
Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (<= 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of
the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either "Eulerian", "Semi-Eulerian", or "Non-Eulerian". Note that all the numbers in the
first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.
Sample Input 1:
7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:
2 4 4 4 4 4 2
Eulerian

Sample Input 2:
6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:
2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:
5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:
3 3 4 3 3
Non-Eulerian

判断一张图是否有欧拉回路,欧拉路径.先用并查集判断连通性,之后判断每个点的度数即可。
#include<map>
#include<set>
#include<ctime>
#include<cmath>
#include<queue>
#include<string>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
using namespace std;
#define ms(x,y) memset(x,y,sizeof(x))
#define rep(i,j,k) for(int i=j;i<=k;i++)
#define per(i,j,k) for(int i=j;i>=k;i--)
#define loop(i,j,k) for (int i=j;i!=-1;i=k[i])
#define inone(x) scanf("%d",&x)
#define intwo(x,y) scanf("%d%d",&x,&y)
#define inthr(x,y,z) scanf("%d%d%d",&x,&y,&z)
#define infou(x,y,z,p) scanf("%d%d%d%d",&x,&y,&z,&p)
#define lson x<<1,l,mid
#define rson x<<1|1,mid+1,r
#define mp(i,j) make_pair(i,j)
#define ft first
#define sd second
typedef long long LL;
typedef pair<int, int> pii;
const int low(int x) { return x&-x; }
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int N = 3e5 + 10;
const double eps = 1e-10;
int n, m, x, y, cnt
, fa
, tot, odd;

int get(int x) { return x == fa[x] ? x : fa[x] = get(fa[x]); }

int main()
{
intwo(n, m);
rep(i, 1, n) fa[i] = i, cnt[i] = 0;
tot = n - 1; odd = 0;
rep(i, 1, m)
{
intwo(x, y);
cnt[x]++; cnt[y]++;
int fx = get(x), fy = get(y);
if (fx == fy) continue;
fa[fx] = fy; tot--;
}
rep(i, 1, n)
{
if (cnt[i] & 1) odd++;
printf("%d%s", cnt[i], i == n ? "\n" : " ");
}
if (!tot && (!odd || odd == 2))
puts(odd ? "Semi-Eulerian" : "Eulerian");
else puts("Non-Eulerian");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: