您的位置:首页 > 其它

csu Parenthesis

2017-03-04 15:52 295 查看
Description

Bobo has a balanced parenthesis sequence P=p1 p2…pn of length n and q questions.

The i-th question is whether P remains balanced after pai and pbi swapped. Note that questions are individual so that they have no affect on others.

Parenthesis sequence S is balanced if and only if:

1. S is empty;

2. or there exists balanced parenthesis sequence A,B such that S=AB;

3. or there exists balanced parenthesis sequence S’ such that S=(S’).

Input

The input contains at most 30 sets. For each set:

The first line contains two integers n,q (2≤n≤105,1≤q≤105).

The second line contains n characters p1 p2…pn.

The i-th of the last q lines contains 2 integers ai,bi (1≤ai,bi≤n,ai≠bi).

Output

For each question, output “Yes” if P remains balanced, or “No” otherwise.

Sample Input

4 2

(())

1 3

2 3

2 1

()

1 2

Sample Output

No

Yes

No

‘(’+1,‘(’-1,前缀和为非负数。‘(’和“)”交换之后,前缀和在 (l,r-1)会减少2,检查前缀的的最小值是否大于2。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;

int a[100005],sum[400005],len;
char s[100005];

void build(int le, int ri ,int rt)
{
if(le == ri)
{
sum[rt] = a[len++];
return;
}
int mid = (le+ri)>>1;
build(le,mid,rt*2);
build(mid+1,ri,rt*2+1);
sum[rt] = min(sum[rt*2],sum[rt*2+1]) ;
}
int query(int le, int ri,int L, int R, int rt)// min操作
{
if(le<=L && R<=ri)
{
return sum[rt];
}
int mid = (L+R)>>1;
int x = 0x7fffffff , y = 0x7fffffff ;
if(mid >= le)  x = query(le,ri, L,   mid, rt*2);
if(mid+1 <= ri) y = query(le,ri, mid+1,R, rt*2+1);
return min(x,y);
}

int main()
{
int n,q;
while(scanf("%d%d",&n,&q) != EOF)
{
scanf("%s",s+1);
a[0] = 0, len = 1;
for(int i=1;i<=n;i++)
{
if(s[i] == '(')
{
a[i] = a[i-1] + 1;
}
else
{
a[i] = a[i-1] - 1;
}
}

build(1,n,1);

for(int i=0;i<q;i++)
{
int l,r;scanf("%d%d",&l,&r);
if(l > r) swap(l,r);
if(s[l] == s[r] || s[l] == ')')
{
printf("Yes\n");
}
else
{
int x = query(l,r-1,1,n,1);
if(x-2<0) printf("No\n");
else  printf("Yes\n");
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: