您的位置:首页 > 其它

UVA-489 Hangman Judge

2017-03-04 15:35 465 查看
In “Hangman Judge,” you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:

1. The contestant tries to solve to puzzle by guessing one letter at a time.

2. Every time a guess is correct, all the characters in the word that match the guess will be “turned over.” For example, if your guess is ‘o’ and the word is “book”, then both ‘o’s in the solution will be counted as “solved”.

3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.

4. If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.

5. If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.

6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out. Your task as the “Hangman Judge” is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

Input

Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of ‘-1’ would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results: You win. You lose. You chickened out.

Sample Input

1

cheese chese

2

cheese abcdefg

3

cheese abcdefgij

-1

Sample Output

Round 1

You win.

Round 2

You chickened out.

Round 3

You lose.

分析:本题需考虑周全。对于每个所猜元素,先判断是否重复,再判断是否在原字符串中,用变量error统计出错个数,根据判断是否全猜中以及出错情况,决定输赢。

Source:

#include<stdio.h>
#include<string.h>
#define MAX 100
int main()
{
int t,i,j;
int error;
char s[MAX],g[MAX];
char n[26],repeat[26];
while(scanf("%d",&t)!=EOF&&t!=-1)
{
error=0;
for(i=0;i<26;i++)
{
n[i]=0;
repeat[i]=0;
}
scanf("%s%s",s,g);
printf("Round %d\n",t);
for(i=0;i<strlen(s);i++)
n[s[i]-'a']++;
for(i=0;i<strlen(g);i++)
{
if(!repeat[g[i]-'a'])
{
repeat[g[i]-'a']=1;
if(!n[g[i]-'a'])
error++;
n[g[i]-'a']=0;
}
for(j=0;j<26;j++)
if(n[j])
break;
if(j<26&&error==7)
{
printf("You lose.\n");
break;
}
if(j==26&&error<7)
{
printf("You win.\n");
break;
}
}
if(i==strlen(g))
printf("You chickened out.\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  UVA