您的位置:首页 > 其它

POJ 2955 (区间dp,划分区间求解)

2017-03-03 19:01 253 查看
Brackets

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7285 Accepted: 3892
Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]


while the following character sequences are not:

(, ], )(, ([)], ([(]


Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such
that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is
a regular brackets sequence.

Given the initial sequence 
([([]])]
, the longest regular brackets subsequence is 
[([])]
.

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters 
(
)
[
, and 
]
; each input test will have length between 1 and 100, inclusive.
The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input
((()))
()()()
([]])
)[)(
([][][)
end

Sample Output
6
6
4
0
6


分析:划分区间求解,状态方程dp(i,j)=max(dp(i,k)+dp(k+1,j)); dp(i,j)表示从i到j的最大长度

AC代码;

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=100+10;
int dp[maxn][maxn];
char s[maxn];
int main(){
while(scanf("%s",s+1)==1){
if(s[1]=='e')break;

int l=strlen(s+1);
memset(dp,0,sizeof(dp));
for(int len=2;len<=l;len++){ //长度
for(int i=1;i<=l-len+1;i++) //起点
{
int j=i+len-1; //终点
if(s[i]=='(' && s[j]==')' || s[i]=='[' && s[j]==']')
dp[i][j]=dp[i+1][j-1]+2;
else dp[i][j]=dp[i][j-1];

for(int k=i;k<j;k++)
dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
}
}

printf("%d\n",dp[1][l]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: