您的位置:首页 > 其它

HDU 2602 - Bone Collector

2017-03-03 15:16 169 查看
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ? 



InputThe first line contain a integer T , the number of cases. 

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.
OutputOne integer per line representing the maximum of the total value (this number will be less than 2 31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1


Sample Output
14


纯01背包题……

二维数组写法:

#include<cstdio>
#include<algorithm>
using namespace std;

unsigned long max_weight[1003][1003];//max_weight[i][j]:前i个骨头中,容量为j的背包里能放的下的最大重量
struct type{
int v;
int w;
}bone[1003];

int main()
{
int n,V;
int t;scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&V);
for(int i=1;i<=n;i++) scanf("%d",&bone[i].w);
for(int i=1;i<=n;i++) scanf("%d",&bone[i].v);

for(int j=0;j<=V;j++){
if(bone[1].v <= j) max_weight[1][j]=bone[1].w;
else max_weight[1][j]=0;
}

for(int i=2;i<=n;i++){
for(int j=0;j<=V;j++){
if(j<bone[i].v) max_weight[i][j]=max_weight[i-1][j];
else max_weight[i][j]=max( max_weight[i-1][j] , max_weight[i-1][ (j-bone[i].v) ] + bone[i].w );
}
}

printf("%d\n",max_weight
[V]);
}
}


减小空间复杂度,滚动一维数组写法:

#include<cstdio>
#include<algorithm>
using namespace std;

unsigned long max_weight[1003];
struct type{
int v;
int w;
}bone[1003];

int main()
{
int n,V;
int t;scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&V);
for(int i=1;i<=n;i++) scanf("%d",&bone[i].w);
for(int i=1;i<=n;i++) scanf("%d",&bone[i].v);

for(int j=0;j<=V;j++){
if(bone[1].v <= j) max_weight[j]=bone[1].w;
else max_weight[j]=0;
}

for(int i=2;i<=n;i++){
for(int j=V;j>=0;j--){
if(j<bone[i].v) max_weight[j]=max_weight[j];
else max_weight[j]=max( max_weight[j] , max_weight[ (j-bone[i].v) ] + bone[i].w );
}
}

printf("%d\n",max_weight[V]);
}
}




内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu