您的位置:首页 > 其它

hdu1241 Oil Deposits

2017-03-03 15:07 316 查看


Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 28580    Accepted Submission(s): 16504


Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each
plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous
pockets. Your job is to determine how many different oil deposits are contained in a grid. 

 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following
this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

 

Sample Output

0
1
2
2

 

DFS连通块个数,从任意的 @ 开始,不停地把邻接的部分用'*'代替。

1次DFS后与初始的这个@连接的所有@就都被替换成了'*',因此直到图中不再存在@为止,

总共进行DFS的次数就是答案了。

//
// Created by Admin on 2017/3/2.
//
#include <cstdio>
#include <iostream>
using namespace std;

int m,n;
char grid[110][110]; //网格坐标

void dfs(int x,int y){ //现在位置(x,y)
grid[x][y]='*'; //将现在所在位置替换为'*'
for(int dx=-1;dx<=1;dx++) //循环遍历移动的八个方向
for(int dy=-1;dy<=1;dy++){
int nx=x+dx,ny=y+dy; //x方向移动dx,y方向移动dy,结果为(nx,ny);
//判断(nx,ny)是否在网格内,以及是否有oil pocket'@'
if(0<=nx && nx<m && 0<=ny && ny<n && grid[nx][ny]=='@')
dfs(nx,ny);
}
return;
}

int main(){
while(cin>>m>>n){
if(m==0||n==0)break;
for(int i=0;i<m;i++)
scanf("%s",grid[i]);
int ans=0;
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
if(grid[i][j]=='@'){ //从有'@'(oil pocket)的地方开始DFS
dfs(i,j);
ans++;
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu dfs