您的位置:首页 > 其它

poj2386 Lake Counting

2017-03-03 14:57 190 查看
Lake Counting

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 32972 Accepted: 16448
Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure
out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.
Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output

* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output
3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

题意: 有一个大小为 N x M 的园子,求有多少不同的水池,连接在一起的认为是同一个水池。

DFS连通块个数,从任意的 W 开始,不停地把邻接的部分用'.'代替。
1次DFS后与初始的这个W连接的所有W就都被替换成了'.',因此直到图中不再存在W为止,总共进行DFS的次数就是答案了。
8个方向共对应了8种状态转移,每个格子作为DFS的参数至多被调用一次,复杂度为O(8xNxM)=O(NxM) 

#include<cstdio>
#include<iostream>
using namespace std;
int n,m;
char field[110][110]; //园子坐标

void dfs(int x,int y) //现在位置(x,y)
{
field[x][y]='.'; //将现在所在位置替换为'.'
for(int dx=-1;dx<=1;dx++){ //循环遍历移动的八个方向
for(int dy=-1;dy<=1;dy++){
int nx=x+dx,ny=y+dy; //x方向移动dx,y方向移动dy,结果为(nx,ny);
//判断(nx,ny)是否在园子内,以及是否有积水
if( 0<=nx && nx<n && 0<=ny && ny<m && field[nx][ny]=='W')
dfs(nx,ny);
}
}
return ;
}

int main()
{
while(cin>>n>>m)
{
int ans=0;
for(int i=0;i<n;i++)
scanf("%s",field[i]);

for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
if(field[i][j]=='W') { //从有'W'(积水)的地方开始DFS
dfs(i,j);
ans++;
}
}
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj dfs