您的位置:首页 > 产品设计 > UI/UE

HDU1159 - Common Subsequence - 动态规划+字符串

2017-03-02 22:17 399 查看
1.题目描述:


Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 37149    Accepted Submission(s): 17011


Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2,
..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length
common subsequence of X and Y. 

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line. 

 

Sample Input

abcfbc abfcab
programming contest
abcd mnp

 

Sample Output

4
2
0

 

Source

Southeastern Europe 2003

 

Recommend

Ignatius

 

2.题意概述:

要你找最长公共子字符串序列

3.解题思路:

裸的dp,如果字符串相同则+1,转移方程:dp[i][j] = max(dp[i - 1][j], dp[i][j - 1]);

4.AC代码:

// E.cpp : 定义控制台应用程序的入口点。
//

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxn 1010
using namespace std;
char s1[maxn], s2[maxn];
int dp[maxn][maxn];
int main()
{
while (scanf("%s%s", s1, s2) != EOF)
{
int len1 = strlen(s1);
int len2 = strlen(s2);
memset(dp, 0, sizeof(dp));
for (int i = 1; i <= len1; i++)
for (int j = 1; j <= len2; j++)
if (s1[i - 1] == s2[j - 1])
dp[i][j] = dp[i - 1][j - 1] + 1;
else
dp[i][j] = max(dp[i - 1][j], dp[i][j - 1]);
printf("%d\n", dp[len1][len2]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 算法 hdu