您的位置:首页 > 其它

练习系统 实验二 All in All

2017-03-02 17:18 239 查看
当前编程题:实验二 进制转换问题(16级) ---All in All

5.问题描述
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending
patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.
Given two strings s and t, you have to decide whether s is a subsequence of t,i.e. if you can remove characters from t such that the concatenation of the remaining characters
is s.
输入形式
The input contains several test cases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by white space. The length of s and t will no
more than 100000.
输出形式
For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
样例输入
4
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
样例输出
Yes
No
Yes
No

说实话这个编的真是很顺哈哈


#include<stdio.h>

#include<string.h>

void handle(char aa[],char bb[])

{
int i,j,flag=0,k=0;
for(i=0;i<strlen(aa);i++)
{
for(j=k;j<strlen(bb);j++)
{
if(aa[i]==bb[j])
    {
  aa[i]='0';
  bb[j]='1';
  k=j;
  }
}
}
for(i=0;i<strlen(aa);i++)
{
if(aa[i]!='0')
{
flag=1;
}
}
if(flag==1)
{
printf("No\n");
}
else
{
printf("Yes\n");
}

}

int main()

{
char aa[1000],bb[1000];
int i,n;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%s%s",aa,bb);
handle(aa,bb);
}
return 0;


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: