您的位置:首页 > 其它

hdu 3038 种类并查集How Many Answers Are Wrong

2017-03-02 07:20 295 查看
[align=left]Problem Description[/align]
TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo
this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the
answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why
asking trouble for himself~~Bad boy)
 
 

[align=left]Input[/align]
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.
 
 

[align=left]Output[/align]
A single line with a integer denotes how many answers are wrong.
 
 

[align=left]Sample Input[/align]

10 5

1 10 100

7 10 28

1 3 32

4 6 41

6 6 1

 
 

[align=left]Sample Output[/align]

1

 
 

[align=left]Source[/align]
2009 Multi-University Training Contest 13 - Host by HIT
 
 

[align=left]Recommend[/align]
gaojie
题面 n个数 m次查询 每次查询代表从第i到j个的数的和为sum比如第一个例子 a1+...+a10=100

问查询错误的次数 题面中 的二三四次查询的结果其实是a1-a10的sum 然而他们并不等于100 故1次假话。

思路 比较经典的种类并查集,刚刚学,还有点不太熟练,比普通的要多一个rank,其他的大体框架基本不变。

每次找父亲节点的时候都要更新一下rank,在unit的时候如果父亲节点相同则要验证一下,具体的一定要自己

想明白,每步的步骤,真正理解发现其实也不是很难。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=200050;
int n,m;
int fa
,rankk
;
void init()
{
for(int i=0;i<=n;i++)
{
fa[i]=i;
rankk[i]=0;
}
}
int findd(int x)
{
if(x==fa[x])return x;
int temp=fa[x];
fa[x]=findd(fa[x]);
rankk[x]+=rankk[temp];
return fa[x];
}
bool unite(int x,int y,int c)
{
int xx=findd(x),yy=findd(y);
if(xx==yy)
{
if(rankk[y]!=rankk[x]+c) return false;
return true;
}
fa[yy]=xx;
rankk[yy]=rankk[x]-rankk[y]+c;
return true;
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
int lies=0;
init();
while(m--)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
if(a>b) swap(a,b);
if(!unite(a-1,b,c)) lies++;
}
printf("%d\n",lies);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM