您的位置:首页 > 其它

Heavy Transportation POJ - 1797

2017-03-01 23:14 375 查看
Language:
Default

Heavy Transportation

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 32906 Accepted: 8734
Description

Background 

Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed
on which all streets can carry the weight. 

Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 

You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's
place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing
of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for
the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5

Sample Output
Scenario #1:
4

思路:这是一个求最短路的变形,是一个求从1到n的最大承载量,也就是从求最小值变成了求最大值,那就是要看两条连接路中小的那一个决定最大承载量。

PS:刚开始用 Dijkstra 还不是很熟练,老是要借助模版,还是要多加练习。

#include <iostream>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
#define MXAN 2010
#define INF 1 << 29

using namespace std;

int mp[MXAN][MXAN];

int main(){
int T, n, m;
int kase = 0;
scanf("%d", &T);
while(T--){
for(int i = 0; i < MXAN; ++i)
for(int j = 0; j < MXAN; ++j){
mp[i][j] = 0; // 将一开始所有路之间的承载量都初始化为零
}
scanf("%d%d", &n, &m);
int x, y, z;
for(int i = 1; i <= m; ++i){
scanf("%d%d%d", &x, &y, &z);
mp[y][x] = mp[x][y] = z; // 这是一个双向路,所以从x到y和从y到x的承载量相同
}
int dis[MXAN];
int book[MXAN] = {0};
for(int i = 1; i <= n; ++i){
dis[i] = mp[1][i]; // 一开始从1到各个点的承载量
}
book[1] = 1;
int u = 0;
for(int i = 1; i < n; ++i){
int max_weight = -1;
for(int j = 1; j <= n; ++j){
if(!book[j] && dis[j] > max_weight){
u = j;
max_weight = dis[j];
}
}
book[u] = 1; // 防止重复计算
for(int j = 1; j <= n; ++j){
if(dis[j] < min(dis[u], mp[u][j])){
dis[j] = min(dis[u], mp[u][j]); // 求最大的承载量
}
}
}
printf("Scenario #%d:\n%d\n\n", ++kase, dis
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: