您的位置:首页 > 编程语言 > C语言/C++

HDU 2222 Keywords Search

2017-03-01 18:48 399 查看
[align=left]Problem Description[/align]
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.

Wiskey also wants to bring this feature to his image retrieval system.

Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.

To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

 

[align=left]Input[/align]
First line will contain one integer means how many cases will follow by.

Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)

Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.

The last line is the description, and the length will be not longer than 1000000.

 

[align=left]Output[/align]
Print how many keywords are contained in the description.
 

[align=left]Sample Input[/align]

1
5
she
he
say
shr
her
yasherhs

 

[align=left]Sample Output[/align]

3

 

[align=left]Author[/align]
Wiskey
 

[align=left]Recommend[/align]
lcy

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

AC自动机~

按key来建立AC自动机,然后查找串中的每一个字符。

就是模板吧?

事实证明,下标要么从1开始要么从0开始,否则查起来会很麻烦……

#include<cstdio>
#include<cstring>

int t,n,c[500001][26],fail[500001],q[500001],head,tail,cnt,w[1000001],len,x,ans,tot[500001];
bool b[500001];
char s[50],ss[1000000];

struct ac{
void add()
{
len=strlen(s);x=1;
for(int i=0;i<len;i++)
{
if(!c[x][s[i]-'a']) c[x][s[i]-'a']=++cnt;
x=c[x][s[i]-'a'];
}
tot[x]++;
}
void getfail()
{
head=0;tail=1;fail[1]=0;q[1]=1;
while(head!=tail)
{
int k=q[++head];
for(int i=0;i<26;i++)
if(c[k][i])
{
int now=fail[k];
while(!c[now][i]) now=fail[now];
fail[c[k][i]]=c[now][i];q[++tail]=c[k][i];
}
}
}
void cal()
{
ans=0;len=strlen(ss);x=1;
for(int i=0;i<len;i++)
{
b[x]=1;
while(!c[x][ss[i]-'a']) x=fail[x];x=c[x][ss[i]-'a'];
if(!b[x]) for(int j=x;j;j=fail[j]) ans+=tot[j],tot[j]=0;
}
printf("%d\n",ans);
}
}ac;

int main()
{
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);cnt=1;
for(int i=0;i<26;i++) c[0][i]=1;
for(int i=1;i<=n;i++) scanf("%s",s),ac.add();
ac.getfail();
scanf("%s",ss);
ac.cal();
for(int i=1;i<=cnt;i++)
{
for(int j=0;j<26;j++) c[i][j]=0;tot[i]=0;fail[i]=0;b[i]=0;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ AC自动机