您的位置:首页 > 其它

简单枚举类型——植物与颜色(枚举类型+switch语句)

2017-03-01 16:31 549 查看
think:

1注意细节(单词输入是否正确,花朵的颜色种类需要注意)

2enum和switch的用法

3enum集合内默认下标从0开始

sdut原题链接

简单枚举类型——植物与颜色

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

请定义具有red, orange, yellow, green, blue, violet六种颜色的枚举类型color,根据输入的颜色名称,输出以下六种植物花朵的颜色:

Rose(red), Poppies(orange), Sunflower(yellow), Grass(green), Bluebells(blue), Violets(violet)。如果输入的颜色名称不在枚举类型color中,例如输入purple,请输出I don’t know about the color purple.

Input

输入数据有多行,每行有一个字符串代表颜色名称,颜色名称最多30个字符,直到文件结束为止。

Output

输出对应颜色的植物名称,例如:Bluebells are blue. 如果输入的颜色名称不在枚举类型color中,例如purple, 请输出I don’t know about the color purple.

Example Input

blue

yellow

purple

Example Output

Bluebells are blue.

Sunflower are yellow.

I don’t know about the color purple.

Hint

请用枚举类型实现。

Author

lxh

以下为accepted代码

#include <stdio.h>
#include <string.h>
int main()
{
enum color {red, orange, yellow, green, blue, violet, no};
enum color a;
char st[44];
while(scanf("%s", st) != EOF)
{
if(strcmp(st, "red") == 0)
a = red;
else if(strcmp(st, "orange") == 0)
a = orange;
else if(strcmp(st, "yellow") == 0)
a = yellow;
else if(strcmp(st, "green") == 0)
a = green;
else if(strcmp(st, "blue") == 0)
a = blue;
else if(strcmp(st, "violet") == 0)
a = violet;
else
a = no;
//printf("a:%d\n", a);
switch(a)
{
case red: printf("Rose are red.\n"); break;
case orange: printf("Poppies are orange.\n"); break;
case yellow: printf("Sunflower are yellow.\n"); break;
case green: printf("Grass are green.\n"); break;
case blue: printf("Bluebells are blue.\n"); break;
case violet: printf("Violets are violet.\n"); break;
case no: printf("I don't know about the color %s.\n", st); break;
}
}
return 0;
}

/***************************************************
User name:
Result: Accepted
Take time: 0ms
Take Memory: 108KB
Submit time: 2017-03-01 16:16:03
****************************************************/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息