您的位置:首页 > 其它

1004. Counting Leaves (30)

2017-03-01 14:54 453 查看
参考http://www.cnblogs.com/wwblog/p/3704428.html

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output “0 1” in a line.

Sample Input

2 1

01 1 02

Sample Output

0 1

/**
2017.3.1
Donald
*/

//1004. Counting Leaves (30)
/**
题意:每一层有几个叶子节点
思路:
用一数组维护记录每层层数,
递归实现
*/

#include<cstdio>
#include<vector>
#include<map>
using namespace std;
#define MAXN 101

int N, M, K;
int levelLeaves[MAXN];              //记录每一层节点数
map<int , vector<int> > nodeMap;    //对应编号的节点有几个子节点

void dfs(int nodeId, int level){
if(nodeMap[nodeId].empty()){
levelLeaves[level] ++;
return ;
}
vector<int>::iterator it = nodeMap[nodeId].begin();
for (; it != nodeMap[nodeId].end(); ++it){
dfs(*it, level + 1);
}
}
int main(void){
int id, childID;
scanf("%d%d", &N, &M);
for(int i = 0; i < M; ++i){
scanf("%d%d", &id, &K);
while(K--){
scanf("%d", &childID);
nodeMap[id].push_back(childID);
}
}
dfs(1, 0);
printf("%d", levelLeaves[0]);
int cnt = levelLeaves[0];
int leaves = N - M;         //叶节点数 = 总节点数 - 非叶节点数
for(int i = 1;  cnt < leaves; ++i){
printf(" %d", levelLeaves[i]);
cnt += levelLeaves[i];
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT