您的位置:首页 > 其它

poj Wireless Network(基础并查集)

2017-02-28 21:26 447 查看
Wireless Network

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by
one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the
communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers
xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 

1. "O p" (1 <= p <= N), which means repairing computer p. 

2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output
FAIL
SUCCESS


代码:
#include<stdio.h
4000
>
#include<math.h>
#include<string.h>
#define maxn  1000+10
int pre[maxn],xi[maxn],yi[maxn],vis[maxn];
int n;
double d;

void init()
{
for(int i=1; i<=n; i++)
pre[i]=i;
}

int Find(int x)
{
int r=x;
while(pre[r]!=r)
r=pre[r];
int i=x,j;
while(i!=r)
{
j=pre[i];
pre[i]=r;
i=j;
}
return r;
}

void join(int x,int y)
{
int fx=Find(x),fy=Find(y);
if(fx!=fy)
pre[fx]=fy;
}

int check(int x1,int y1,int x2,int y2)
{
if(d*d>=((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)))
return 1;
return 0;
}

int main()
{
int i,j;
scanf("%d%lf",&n,&d);
init();
for(i=1; i<=n; i++)
scanf("%d%d",&xi[i],&yi[i]);
char ss[10];
while(~scanf("%s",ss))
{
int x,y;
if(ss[0]=='O')
{
scanf("%d",&x);
vis[x]=1;
for(i=1; i<=n; i++)
if(vis[i]&&check(xi[i],yi[i],xi[x],yi[x])&&x!=i)
join(i,x);
}
else
{
scanf("%d%d",&x,&y);
//            for(i=1;i<=n;i++)
//                printf("pre[%d]=%d\n",i,pre[i]);
if(Find(x)==Find(y))//注意这里,目前的pre[x]并不一定等于目前的pre[y],所以用Find[]
printf("SUCCESS\n");
else
printf("FAIL\n");
}
}
return 0;
}


ps:错误地认为pre[x]==pre[y]就是判断结果的条件,谨记
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: