您的位置:首页 > 编程语言 > C语言/C++

POJ 1260-Pearls(DP-买珍珠)

2017-02-28 21:09 387 查看
Pearls

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9084 Accepted: 4571
Description

In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary
people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl
in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class. 

Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain
quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl. 

Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is
actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the 

prices remain the same. 

For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro. 

The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program. 

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one. 

Input

The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai
needed in a class (1 <= ai <= 1000). 

The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers. 

Output

For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list. 

Sample Input
2
2
100 1
100 2
3
1 10
1 11
100 12

Sample Output
330
1344

Source

Northwestern Europe 2002


题目意思:

有C种珍珠,分别给出其需求数目和单价。单价越高品质越好。
某种珍珠单独购入的话需要多加10个数目的钱,但是如果和高品质的珍珠一起购买的话,就只需要多加10个高品质珍珠的价钱。
例如,10欧元类别的需要5个珍珠,20欧元类别的需要100个珍珠。这通常将花费:(5 + 10)* 10 +(100 + 10)* 20 = 2350欧元。但是如果所有105个珍珠都以20欧元类别的购入,则只有:(5 + 100 + 10)* 20 = 2300欧元。

计算购入所有珍珠的最低花费。


解题思路:

dp[i]表示前i种珍珠的最低购入价。
DP方程是:dp[i]=min(dp[i],dp[j-1]+第i种的单价*(第j种到第i种的总数目+10));

输入第i种时的初始dp[i]是dp[i-1]+单独购入第i种,然后遍历1~i找到合适的j进行划分,使得第1种到第j-1种分别单独购入且第j种到第i种一起购入时总花费最小。

#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define INF 0x3f3f3f3f
#define MAXN 1100
struct Node
{
int n,m;//需求数目、价格
} a[MAXN];
int dp[MAXN];//dp[i]表示前i种珍珠的最低购入价
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("G:/cbx/read.txt","r",stdin);
//freopen("F:/cb/out.txt","w",stdout);
#endif
ios::sync_with_stdio(false);
cin.tie(0);
int t;
cin>>t;
while(t--)
{
int c;//种类数目
cin>>c;
memset(dp,0,sizeof(dp));
for(int i=1; i<=c; ++i)
{
cin>>a[i].n>>a[i].m;
dp[i]=dp[i-1]+a[i].m*(a[i].n+10);//第i种的购入价加上前i-1种的最低购入价
for(int j=1; j<=i; ++j)//从j到i的所有珍珠一起购买
{
int sum=0;//从j到i的所有珍珠数目
for(int k=j; k<=i; ++k)
sum+=a[k].n;
dp[i]=min(dp[i],dp[j-1]+a[i].m*(sum+10));//要加上前j-1种的最低购入价dp[j-1]
}
}
cout<<dp[c]<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息