您的位置:首页 > 其它

紫书章四例1——UVA1339 Ancien Cipher

2017-02-27 21:56 375 查看
Ancient Roman empire had a strong government system with various departments, including a secret

service department. Important documents were sent between provinces and the capital in encrypted

form to prevent eavesdropping. The most popular ciphers in those times were so called substitution

cipher and permutation cipher.

Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all

letters must be different. For some letters substitute letter may coincide with the original letter. For

example, applying substitution cipher that changes all letters from
A' to
Y’ to the next ones in the

alphabet, and changes
Z' to
A’, to the message \VICTORIOUS” one gets the message \WJDUPSJPVT”.

Permutation cipher applies some permutation to the letters of the message. For example, ap-

plying the permutation ⟨2; 1; 5; 4; 3; 7; 6; 10; 9; 8⟩ to the message \VICTORIOUS” one gets the message

\IVOTCIRSUO”.

It was quickly noticed that being applied separately, both substitution cipher and permutation

cipher were rather weak. But when being combined, they were strong enough for those times. Thus,

the most important messages were rst encrypted using substitution cipher, and then the result was

encrypted using permutation cipher. Encrypting the message \VICTORIOUS” with the combination of

the ciphers described above one gets the message \JWPUDJSTVP”.

Archeologists have recently found the message engraved on a stone plate. At the rst glance it

seemed completely meaningless, so it was suggested that the message was encrypted with some substi-

tution and permutation ciphers. They have conjectured the possible text of the original message that

was encrypted, and now they want to check their conjecture. They need a computer program to do it,

so you have to write one.

Input

Input le contains several test cases. Each of them consists of two lines. The rst line contains the

message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so

the encrypted message contains only capital letters of the English alphabet. The second line contains

the original message that is conjectured to be encrypted in the message on the rst line. It also contains

only capital letters of the English alphabet.

The lengths of both lines of the input le are equal and do not exceed 100.

Output

For each test case, print one output line. Output
YES' if the message on the rst line of the input le

could be the result of encrypting the message on the second line, or
NO’ in the other case.

Sample Input

JWPUDJSTVP

VICTORIOUS

MAMA

ROME

HAHA

HEHE

AAA

AAA

NEERCISTHEBEST

SECRETMESSAGES

Sample Output

YES

NO

YES

YES

NO

这个题,感觉是要看懂题目。映射不一定就是题目中说的右一位映射。。。

然后因为字母可以重排,我们又不知道其中的映射关系是什么,所以就可以想到相同的字母映射之后还是相同的,所以我们直接一个排序,看相同字符个数是不是还是相同就可以了~

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;

char a[105];
char b[105];
int c1[30];
int c2[30];
int main()
{
while(scanf("%s",a)!=EOF)
{
memset(c1,0,sizeof(c1));
memset(c2,0,sizeof(c2));
scanf("%s",b);
int alen=strlen(a);
for(int i=0;i<alen;i++)
{
c1[a[i]-'A']++;
c2[b[i]-'A']++;
}
sort(c1,c1+26);
sort(c2,c2+26);
int k=0;
for(k=0;k<26;k++)
{
if(c1[k]!=c2[k])
{
printf("NO\n");
break;
}
}
if(k==26)
printf("YES\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: