您的位置:首页 > 其它

poj3278 Catch That Cow BFS

2017-02-27 21:36 411 查看
Catch That Cow

Time Limit: 2000MS Memory Limit: 65536KB

Submit Statistic

Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Example Input

5 17

Example Output

4

代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef struct node
{
int data;
int step;
}ST;
ST a[500055], t;//数组模拟队列
int vis[500055];
int head, last;//标记首,和尾
void bfs(int n, int k)//广度优先搜索
{
if(n == k)
{
printf("%d\n", a[head].step);//满足条件输出
return ;//别忘了
}
t = a[head++];
int i, j;
for(i = 0; i < 3; i++)//下一步分为三种情况
{
if(i == 0 && !vis[t.data - 1] && t.data >= 1)//防止越界
{
a[last].data = t.data - 1;
a[last++].step = t.step + 1;
vis[t.data - 1] = 1;
}
else if(i == 1 && !vis[t.data + 1] && t.data <= k)//防止越走越远没意义
{
a[last].data = t.data + 1;
a[last++].step = t.step + 1;
vis[t.data + 1] = 1;
}
else if(i == 2 && !vis[t.data * 2] && t.data <= k)//防止越走越远没意义
{
a[last].data = t.data * 2;
a[last++].step = t.step + 1;
vis[t.data * 2] = 1;
}
}
bfs(a[head].data, k);
}
int main()
{
int n, k;
while(~scanf("%d %d", &n, &k))
{
memset(vis, 0, sizeof(vis));
head = last = 0;
a[last].step = 0;
a[last++].data = n;
vis
= 1;
bfs(a[head].data, k);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  bfs poj