您的位置:首页 > 其它

章三例题2——UVA 10082

2017-02-26 23:38 309 查看
WERTYU

A common typing error is to place the hands on the keyboard one row to the right of the correct position. So “Q” is typed as “W” and “J” is typed as “K” and so on. You are to decode a message typed in this manner.

Input

Input consists of several lines of text. Each line may contain digits, spaces, upper case letters (except Q, A, Z), or punctuation shown above [except back-quote (`)]. Keys labelled with words [Tab, BackSp, Control, etc.] are not represented in the input.

Output

You are to replace each letter or punctuation symbol by the one immediately to its left on the QWERTY keyboard shown above. Spaces in the input should be echoed in the output.

Sample Input

O S, GOMR YPFSU/

Sample Output

I AM FINE TODAY.

题意就是输出给的字符在键盘左边的一个字符。然后空格还是空格。需要注意的是\ 需要\ 才能表示为\

常量数组的运用

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
char s[]="`1234567890-=QWERTYUIOP[]\\ASDFGHJKL;'ZXCVBNM,./";

int main()
{
char c;
while((c=getchar())!=EOF)
{
int len=strlen(s);
int flag=0;
int i;
for(i=1;i<len&&s[i]!=c;i++);//直到找到相等的那个字符
if(s[i]==c)
printf("%c",s[i-1]);
else
printf("%c",c);//空格的时候
}
return 0;
}


//引用曹大神

使用常量数组建立对应关系

使用fgets()输入带空格的字符串 (不推荐gets())

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn = 1e4;

char buf[maxn];
char arr[] = { "`1234567890-=QWERTYUIOP[]\\ASDFGHJKL;'ZXCVBNM,./"};

char find(int id){
for (int i = 0; i < strlen(arr); ++i){
if (buf[id] == arr[i]){
return arr[i - 1];
}
}
}

int main(){
while (fgets(buf, maxn, stdin)){
int len = strlen(buf);
for (int i = 0; i < len-1; ++i){
if (buf[i] != ' '){
buf[i] = find(i);
}
printf("%c", buf[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: