您的位置:首页 > 其它

POJ1988:Cube Stacking(并查集)

2017-02-26 23:37 375 查看
Cube Stacking

Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 24664 Accepted: 8652
Case Time Limit: 1000MS
Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 

moves and counts. 

* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 

* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For
count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output
1
0
2

Source

USACO 2004 U S Open

思路:简单并查集,num[i]记录i点距离根节点多远,sum[i]记录i的儿子+自己数量。

# include <iostream>
# include <cstring>
# include <cstdio>
# include <algorithm>
# define MAXN 30000
using namespace std;
int pre[MAXN+1], sum[MAXN+1], num[MAXN+1];
int find(int x)
{
if(x == pre[x])
return pre[x];
else
{
int t = pre[x];
pre[x] = find(pre[x]);
num[x] = num[t] + num[x];
return pre[x];
}
}

int main()
{
int p, a, b;
char c;
while(~scanf("%d",&p))
{
for(int i=1; i<=MAXN; ++i)
{
pre[i] = i;
sum[i] = 1;
num[i] = 0;
}
while(p--)
{
getchar();
c = getchar();
if(c == 'M')
{
scanf("%d%d",&a,&b);
int px = find(a);
int py = find(b);
if(px != py)
{
pre[px] = py;
num[px] = sum[py];
sum[py] += sum[px];
}
}
else
{
scanf("%d",&a);
find(a);
printf("%d\n",num[a]);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: