您的位置:首页 > 其它

HDU 2095 - find your present (2)

2017-02-26 20:32 405 查看
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 23060    Accepted Submission(s): 9172



Problem Description

In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number
will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is
the number that different from all the others.

 

Input

The input file will consist of several cases. 

Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

 

Output

For each case, output an integer in a line, which is the card number of your present.

 

Sample Input

5
1 1 3 2 2
3
1 2 1
0

 

Sample Output

3
2

HintHint
use scanf to avoid Time Limit Exceeded

 

Author

8600

 

Source

HDU 2007-Spring Programming
Contest - Warm Up (1)

 

Recommend

8600   |   We have carefully selected several similar problems for you:  2097 2099 2096 2094 1008 

简单地说,就是输入奇数个数字,找出那个成单的数字,下面是两种思路(因为感觉用亦或实在有点反人类思维……所以你就用刚学的STL整了一下)

①使用map,一一对应:

#include<cstdio>
#include<map>
using namespace std;
int main()
{
int n;
while(scanf("%d",&n) && n>0){
map<int,int> num;
for(int i=0;i<n;i++){
int temp;scanf("%d",&temp);
if(!num.count(temp)) num[temp]=0;
num[temp]++;
}
for(map<int,int>::iterator i=num.begin();i!=num.end();i++){
if((i->second)%2 != 0) {printf("%d\n",i->first);break;}
}
}
return 0;
}


②使用sort快排:

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
int i,n;while(scanf("%d",&n) && n>0){
int *num=(int *
4000
)malloc(n*sizeof(int));
for(i=0;i<n;i++) scanf("%d",&num[i]);
sort(num,num+n);
for(i=0;i<n;i+=2) if(num[i]!=num[i+1]) {printf("%d\n",num[i]);break;}
}
}
一般来说,最好在找到那个数字之后就break,要不然还是会time limit exceeded……
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu