您的位置:首页 > 其它

UVA-455 Periodic Strings

2017-02-26 20:19 288 查看
A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string ”abcabcabcabc” has period 3, since it is formed by 4 repetitions of the string ”abc”. It also has periods 6 (two repetitions of ”abcabc”) and 12 (one repetition of ”abcabcabcabc”).

Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input

1

HoHoHo

Sample Output

2

分析:循环周期长度,逐一判断每个子串是否相等。

Source:

#include<stdio.h>
#include<string.h>
int main()
{
int t,i,l,k;
char s[81];
scanf("%d",&t);
while(t--)
{
scanf("%s",s);
l=strlen(s);
for(i=1;i<=l;i++)
if(l%i==0)
{
for(k=i;k<l;k++)
if(s[k]!=s[k%i])
break;
if(k==l)
{
printf("%d\n",i);
break;
}
}
if(t)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  UVA