您的位置:首页 > 其它

hdu The Shortest Path in Nya Graph(建图+spfa)

2017-02-26 15:33 274 查看
 The Shortest Path in Nya Graph

Problem Description

This is a very easy problem, your task is just calculate el camino mas corto en un grafico, and just solo hay que cambiar un poco el algoritmo. If you do not understand a word of this paragraph, just move on.

The Nya graph is an undirected graph with "layers". Each node in the graph belongs to a layer, there are N nodes in total.

You can move from any node in layer x to any node in layer x + 1, with cost C, since the roads are bi-directional, moving from layer x + 1 to layer x is also allowed with the same cost.

Besides, there are M extra edges, each connecting a pair of node u and v, with cost w.

Help us calculate the shortest path from node 1 to node N.

 

Input

The first line has a number T (T <= 20) , indicating the number of test cases.

For each test case, first line has three numbers N, M (0 <= N, M <= 105) and C(1 <= C <= 103), which is the number of nodes, the number of extra edges and cost of moving between adjacent layers.

The second line has N numbers li (1 <= li <= N), which is the layer of ith node belong to.

Then come N lines each with 3 numbers, u, v (1 <= u, v < =N, u <> v) and w (1 <= w <= 104), which means there is an extra edge, connecting a pair of node u and v, with cost w.

 

Output

For test case X, output "Case #X: " first, then output the minimum cost moving from node 1 to node N.

If there are no solutions, output -1.

 

Sample Input

2
3 3 3
1 3 2
1 2 1
2 3 1
1 3 3

3 3 3
1 3 2
1 2 2
2 3 2
1 3 4

 

Sample Output

Case #1: 2
Case #2: 3

ps:这道题主要就是难在建图上了,要将层抽象出来成为n个点(对应编号依次为n+1~n+n),然后层与层建边(相邻层都有点才能建边),点与点建边,层与该层上的点建边(边长为0),点与相邻层建边(边长为c)

代码:

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;

#define maxn 200000+10
#define maxv 800000+10
#define mem(a,b)  memset(a,b,sizeof(a))
const int inf=0x3f3f3f3f;
struct node
{
int v,w,next;
} G[maxv];
int d[maxn],first[maxn],lay[maxn];
bool inq[maxn];
int n,m,len;
queue<int>q;

void spfa()
{
int i,st;
d[1]=0,inq[1]=1;
while(!q.empty())
q.pop();
q.push(1);
while(!q.empty())
{
st=q.front();
q.pop();
inq[st]=0;
for(i=first[st]; i!=-1; i=G[i].next)
{
int v=G[i].v,w=G[i].w;
if(d[v]>d[st]+w)
{
d[v]=d[st]+w;
if(!inq[v])
{
inq[v]=1;
q.push(v);
}
}
}
}
}

void add_egde(int u,int v,int w)
{
G[len].v=v,G[len].w=w;
G[len].next=first[u];
first[u]=len++;
}

int main()
{
int t,k=1,c;
scanf("%d",&t);
while(k<=t)
{
mem(first,-1);
mem(lay,0);
mem(inq,0);
scanf("%d%d%d",&n,&m,&c);
len=1;
int i,u,v,w,level;
for(i=1;i<=n;i++)
{
scanf("%d",&level);
lay[i]=level;
inq[level]=1;
}
for(i=1; i<n; i++)
{
if(inq[i]&&inq[i+1])//两层都出现过点,相邻层才建边
add_egde(i+n,i+n+1,c);
add_egde(i+n+1,i+n,c);
}
for(i=1; i<=n; i++)//层到点建边   点到相邻层建边
{
d[i]=d[i+n]=inf;
inq[i]=inq[i+n]=0;
add_egde(n+lay[i],i,0);
if(lay[i]>1)
add_egde(i,lay[i]+n-1,c);
if(lay[i]<n)
add_egde(i,lay[i]+n+1,c);
}
for(i=1; i<=m; i++)//点到点建边
{
scanf("%d%d%d",&u,&v,&w);
add_egde(u,v,w);
add_egde(v,u,w);
}
spfa();
if(d
==inf||n==0)
printf("Case #%d: -1\n",k++);
else
printf("Case #%d: %d\n",k++,d
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: