您的位置:首页 > 其它

POJ1703 Find Them,Catch Them 种类并查集

2017-02-26 13:51 337 查看
1.题目描述:

Find them, Catch them

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 43863 Accepted: 13513
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 

where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.

Source

POJ Monthly--2004.07.18

2.题意概述:

n个罪犯,m组关系,有2个敌对帮派,D a b表示a,b在不同帮派,A a b表示询问a,b是否是在一个帮派。

3.解题思路:

因为查询有三种状态,一个是团伙,一个不是团伙,一个是不清晰,所以考虑用类别偏移,每次连儿子保证和父亲不是一个帮派,同时更新父亲,然后find时候注意回溯一下。

然后因为是种类并查集,还有第二种做法,核心思路是一样的,类似于食物链 开 2 * N 个并查集,分别表示他和他敌人,具体实现以后有时间再更新orz

4.AC代码:

#include <stdio.h>
#define maxn 100010
using namespace std;
int ans[maxn], pa[maxn];

void init(int n)
{
for (int i = 0; i <= n; i++)
{
ans[i] = 0;
pa[i] = i;
}
}
int findset(int x)
{
int rt;
if (pa[x] != x)
{
rt = findset(pa[x]);
ans[x] = ans[x] ^ ans[pa[x]];//类别偏移
return pa[x] = rt;
}
return x;
}
void unionset(int a, int b)
{
int a1 = findset(a);
int b1 = findset(b);
pa[a1] = b1;
ans[a1] = ~(ans[b] ^ ans[a]);//类别偏移
}
int main()
{
int n, m, a, b;
char c;
int t;
scanf("%d", &t);
while (t--)
{
scanf("%d%d\n", &n, &m);
init(n);
for (int i = 1; i <= m; i++)
{
scanf("%c %d %d\n", &c, &a, &b);
if (c == 'D')
unionset(a, b);
else
{
if (n == 2)    //特殊解
puts("In different gangs.");
else if (findset(a) == findset(b))
{
if (ans[a] == ans[b])
puts("In the same gang.");
else
puts("In different gangs.");
}
else
puts("Not sure yet.");
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 算法 poj