您的位置:首页 > 其它

HDU-6016 count the sheep

2017-02-26 12:22 453 查看


Count the Sheep

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 354    Accepted Submission(s): 157


Problem Description

Altough Skipping the class is happy, the new term still can drive luras anxious which is of course because of the tests! Luras became worried as she wanted to skip the class, as well as to attend the BestCoder and also to prepare for tests at the same time.

However, As the result of preparing for tests, luras had no time to practice programing. She didn't want to lose her rating after attending BC. In the end, she found BCround92's writer snowy_smile for help, asking him to leak her something.

Snowy_smile wanted to help while not leaking the problems. He told luras, the best thing to do is to take a good rest according to the following instructions first.

"Imagine you are on the endless grassland where there are a group of sheep. And n sheep of them are silent boy-sheep while m sheep are crying girl-sheep. And there are k friend-relationships between the boy-sheep and girl-sheep.Now You can start from any sheep,
keep counting along the friend relationship. If you can count 4 different sheep, you will exceed 99% sheep-counters and fall asleep."

Hearing of the strange instructions, luras got very shocked. Still, she kept counting. Sure enough, she fell asleep after counting 4 different sheep immediately. And, she overslept and missed the BestCoder in the next day. At a result, she made it that not
losing her rating in the BCround92!!!

However, you don't have the same good luck as her. Since you have seen the 2nd problem, you are possible to have submitted the 1st problem and you can't go back.

So, you have got into an awkward position. If you don't AC this problem, your rating might fall down.

You question is here, please, can you tell that how many different 4-sheep-counting way luras might have before her sleep?

In another word, you need to print the number of the "A-B-C-D" sequence, where A-B, B-C, C-D are friends and A,B,C,D are different.

 

Input

The first line is an integer T which indicates the case number.

and as for each case, there are 3 integers in the first line which indicate boy-sheep-number, girl-sheep-number and friend-realationship-number respectively.

Then there are k lines with 2 integers x and y in each line, which means the x-th boy-sheep and the y-th girl-sheep are friends.

It is guaranteed that——

There will not be multiple same relationships.

1 <= T <= 1000

for 30% cases, 1 <= n, m, k <= 100

for 99% cases, 1 <= n, m, k <= 1000

for 100% cases, 1 <= n, m, k <= 100000

 

Output

As for each case, you need to output a single line.

there should be 1 integer in the line which represents the number of the counting way of 4-sheep-sequence before luras's sleep.

 

Sample Input

3
2 2 4
1 1
1 2
2 1
2 2
3 1 3
1 1
2 1
3 1
3 3 3
1 1
2 1
2 2

 

Sample Output

8
0
2

 

Source

BestCoder Round #92

思路:转化为一条直线上有4个点n1,n2,n3,n4,男女相隔站的问题。

           令一对认识的男女站在n2,n3。

           n2认识的站n1,n3认识的站n4;

           一对的种类为(n1-1)*(n4-1);

           然后k对累加即可。

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

#define Maxn 100010

typedef long long ll;
ll a[Maxn],b[Maxn];
ll na[Maxn],nb[Maxn];

int main(){
int t,n,m,k;
scanf("%d",&t);
while(t--){
memset(na,0,sizeof(na));
memset(nb,0,sizeof(nb));
scanf("%d%d%d",&n,&m,&k);
for(int i=1;i<=k;i++){
scanf("%I64d %I64d",&a[i],&b[i]);
na[a[i]]++;
nb[b[i]]++;
}
ll sum=0;
for(int i=1;i<=k;i++){
sum+=(na[a[i]]-1)*(nb[b[i]]-1);
}
printf("%I64d\n",sum*2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: