您的位置:首页 > 产品设计 > UI/UE

Number Sequence 【打表】+【找规律】

2017-02-26 10:33 316 查看


Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 63052    Accepted Submission(s): 14475

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

Output

For each test case, print the value of f(n) on a single line.

 

Sample Input

1 1 3
1 2 10
0 0 0

 

Sample Output

2
5

 
4000

Author

CHEN, Shunbao

 

Source

ZJCPC2004

 

Recommend

JGShining

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

题意: 输入 A,B,n 求f(n)

思路: 1  可以用数组来模拟这种递归(居然才知道0.0)

2  一看 n 值那么大,就知道 肯定会超时间按照一般方法 ,所以一定可以另辟蹊径,所以就想到了,可能会有周期性即循环 

所以就打表 一看 确实有规律,不过,不同的a,b,周期不同,所以 要打表来记录 周期

        3如果使用数组或者递归都会爆栈,注意到题目中的数都是对7取余,所以相邻的两个数的组合最多有49中,所以最多49次循环就会从头开始循环,这是就可以不用继续执行了,然后将n对i取余,根据余数就可以得到结果。

4 在递归关系中,如果  连续  两个数和 之前的 连续 两个数 相同,那么由递归关系 得到的值一定会是相同的,即一定会有循环

代码

#include<iostream>  

#include<stdio.h>  

using namespace std;  

int f[100000005];  

int main()  

{  

    int a,b,n,i,j;  

  

    f[1]=1;f[2]=1;  

    while(scanf("%d%d%d",&a,&b,&n))  

    {  

        int s=0;//记录周期  

        if(a==0&&b==0&&n==0) break;  

        for(i=3;i<=n;i++)  

        {  

            f[i]=(a*f[i-1]+b*f[i-2])%7;  

            for(j=2;j<i;j++)  

            if(f[i-1]==f[j-1]&&f[i]==f[j])//
 由上述的4得  

            {  

                s=i-j;  

                //cout<<j<<" "<<s<<" >>"<<i<<endl;  

                break;  

            }  

            if(s>0) break;  

        }  

        if(s>0){  

  

                 f
=f[(n-j)%s+j];  

                 //cout<<"f["<<n<<"]:="<<"f["<<(n-j)%s+j<<"] "<<endl;  

               }  

        cout<<f
<<endl;  

  

    }  

    return 0;  

}  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: