您的位置:首页 > 其它

PAT A1098. Insertion or Heap Sort (25)

2017-02-26 00:49 288 查看
According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts
it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than
a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed
that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that
the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:
10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:
Heap Sort
5 4 3 1 0 2 6 7 8 9


提交代码
#include <cstdio>
#include <algorithm>
using namespace std;
const int Max = 1111;
int n;
int start[Max],change[Max],test[Max];
bool IsSame(int a[],int b[])
{
for(int i=1;i<=n;i++)
{
if(a[i]!=b[i])
{
return false;
}
}
return true;
}
bool InsertSort()
{
bool flag=false;
for(int i=2;i<=n;i++)
{
if(i>2&&IsSame(test,change))
{
flag =true;
}
sort(change,change+i+1);
if(flag==true) return true;
}
return false;
}
void FindMax(int a,int b)
{
int i=a;
int j=2*i;
while(j<=b)
{
if(j+1<=b&&change[j]<change[j+1])
{
j=j+1;
}
if(change[j]>change[i])
{
swap(change[i],change[j]);
i=j;
j=2*i;
}
else break;
}
}
void HeapSort()
{
for(int i=n/2;i>=1;i--)
{
FindMax(i,n);//从下往上走,堆排序!
}
bool flag=false;
for(int i=n;i>1;i--)
{
if(i<n&&IsSame(change,test))
{
flag = true;
}
swap(change[1],change[i]);
FindMax(1,i-1);//不断将最大的放在最后
if(flag==true)
{
for(int v=1;v<=n;v++)
{
printf("%d",change[v]);
if(v<n) printf(" ");
}
return ;
}
}
}
int main()
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d",&start[i]);
change[i]=start[i];
}
for(int i=1;i<=n;i++)
{
scanf("%d",&test[i]);
}
if(InsertSort())
{
printf("Insertion Sort\n");
for(int i=1;i<=n;i++)
{
printf("%d",change[i]);
if(i<n) printf(" ");
}
}
else
{
printf("Heap Sort\n");
for(int i=1;i<=n;i++)
{
change[i]=start[i];
}
HeapSort();
}
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: