您的位置:首页 > 其它

UVA-1583 Digit Genarator

2017-02-25 22:00 295 查看
For a positive integer N, the digit-sum of N is defined as the sum of N itself and its digits. When M is the digitsum of N, we call N a generator of M.

For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256.

Not surprisingly, some numbers do not have any generators and some numbers have more than one generator. For example, the generators of 216 are 198 and 207.

You are to write a program to find the smallest generator of the given integer.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case takes one line containing an integer N, 1 ≤ N ≤ 100,000.

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any generators, print ‘0’.

Sample Input

3

216

121

2005

Sample Output

198

0

1979

分析:先反向制作generator的数表,之后直接输出答案。

Source:

#include<stdio.h>
int a[100001];
int main()
{
int t,n,sum,x,i;
scanf("%d",&t);
for(i=1;i<=100000;i++)
{
sum=i;
x=i;
while(x)
{
sum+=x%10;
x/=10;
}
if(sum<=100000&&!a[sum])
a[sum]=i;
}
while(t--)
{
scanf("%d",&n);
printf("%d\n",a
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  UVA