您的位置:首页 > 运维架构

POJ1442 Black Box 优先队列(堆维护)+思维

2017-02-25 15:54 525 查看
1.题目描述:

Black Box

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12573 Accepted: 5154
Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 

GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer

(elements are arranged by non-descending)

1 ADD(3)      0 3

2 GET         1 3                                    3

3 ADD(1)      1 1, 3

4 GET         2 1, 3                                 3

5 ADD(-4)     2 -4, 1, 3

6 ADD(2)      2 -4, 1, 2, 3

7 ADD(8)      2 -4, 1, 2, 3, 8

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8

9 GET         3 -1000, -4, 1, 2, 3, 8                1

10 GET        4 -1000, -4, 1, 2, 3, 8                2

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8


It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 

Let us describe the sequence of transactions by two integer arrays: 

1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence
we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 

Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.
Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.
Sample Input
7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output
3
3
1
2

Source

Northeastern Europe 1996
2.题意概述:
当时题目看了好一会,不容易懂,大概意思是给定M个数,每次可以插入序列一个数;再给N个数,表示在插入第几个数时输出一个数,第一次输出序列中最小的,第二次输出序列中第二小的……以此类推,直到输出N个数。

对于样例:

7 4

3 1 -4 2 8 -1000 2

1 2 6 6

7代表下面给定7个数的数字序列,4可以理解为四次查询, 1 2 6 6为查讯,第一次查询是求数字序列只有前一个数(3)时,此时的第一小的数字,即1,第二次查询是求数字序列只有前2个数(3 1)时,此时的第二小的数字,即 3,第三次查询是求数字序列只有前6个数时(3,1,-4,2,8,-1000),此时的第三小的数字,即1,第四次查询是求数字序列只有前6个数时,此时的第四小的数字。 

3.解题思路:

因为输出时是按照先输出最小的,再输出第二小这样的方式输出的,相当于依次输出一个有序序列中的值。但因为这个序列不是固定不变的,而是不断的在更新,所以用数组是无法实现的。我们可以用堆(优先队列)来做。

定义两个堆,一个用来存储前k小的数(大顶堆),大数在前,小数在后;另一个优先队列第k+1小到最大的数(小顶堆),小数在前,大数在后。每次拿到一个数,先判断第一个优先队列中的数满不满k个,如果不满k个,则直接把这个数压入到第一个队列;如果满k个,判断这个数和第一个优先队列中的第一个数的大小:如果比第一个数大,就压入第二个优先队列;如果比第一个数小,就把第一个优先队列的队首元素弹出压入第二个队列,把这个新数压入第一个优先队列。输出时,如果第一个优先队列里的元素个数小于k,则先把第二个优先队列里的队首元素弹出压入第一个优先队列,然后输出第一个优先队列的队首元素;如果满k个,则直接输出第一个优先队列的队首元素。

4.AC代码:

#include <iostream>
#include <stdio.h>
#include <queue>
#include <algorithm>
#include <functional>
#define maxn 303000
using namespace std;
typedef long long ll;
ll num[maxn];
int n, m;
priority_queue<ll>big;
priority_queue<ll, vector<ll>, greater<ll> >small;
int main()
{
int m, n;
scanf("%d%d", &m, &n);
for (int i = 1; i <= m; i++)
scanf("%lld", &num[i]);
int u, cnt = 1;
for (int i = 1; i <= n; i++)
{
scanf("%d", &u);
while (cnt <= u)
{
small.push(num[cnt]);
if (!big.empty() && small.top() < big.top())//小顶堆里面的数不能比大顶堆里面的数小
{
ll n1 = big.top();
ll n2 = small.top();
big.pop();
small.pop();
big.push(n2);
small.push(n1);
}
cnt++;
}
printf("%lld\n", small.top());
big.push(small.top());//这句话很关键,保证了在求第k个最小数时,大顶堆里面保存的是前k-1个最小数
small.pop();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  算法 acm poj