您的位置:首页 > 其它

POJ 2955 Brackets (区间DP入门)

2017-02-24 13:08 309 查看
Brackets

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7208 Accepted: 3861
Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]


while the following character sequences are not:

(, ], )(, ([)], ([(]


Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such
that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is
a regular brackets sequence.

Given the initial sequence 
([([]])]
, the longest regular brackets subsequence is 
[([])]
.

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters 
(
)
[
, and 
]
; each input test will have length between 1 and 100, inclusive.
The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input
((()))
()()()
([]])
)[)(
([][][)
end

Sample Output
6
6
4
0
6


if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.

这里已经把转移方程告诉你啦!

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn = 105;
int dp[maxn][maxn];
char str[maxn];
int main()
{
while(~scanf("%s", str))
{
if(!strcmp(str, "end"))
break;
memset(dp, 0, sizeof(dp));
int n = strlen(str);
for(int len = 1; len < n; len++)
{
for(int i = 0; i+len < n; i++)
{
int j = i + len;
if(str[i] == '(' && str[j] == ')' || str[i] == '[' && str[j] == ']')
dp[i][j] = dp[i+1][j-1] + 2;
for(int k = i; k < j; k++)
{
dp[i][j] = max(dp[i][j], dp[i][k]+dp[k+1][j]);
}
}
}
printf("%d\n", dp[0][n-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: