您的位置:首页 > 其它

POJ-1088-滑雪(记忆化搜索)

2017-02-21 18:40 477 查看
滑雪

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 95035 Accepted: 36011

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子

1 2 3 4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-…-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5

1 2 3 4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

Sample Output

25

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<string.h>
using namespace std;
const int maxn=105;
int map[maxn][maxn];
int DP[maxn][maxn];
int dis[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
int R,C;
int DFS(int x,int y)
{
if(DP[x][y]!=-1)
return DP[x][y];//搜过的不再搜索
int result=1;
for(int i=0;i<4;i++)
{
int xx=x+dis[i][0];
int yy=y+dis[i][1];
if(xx<=0||xx>R||yy<=0||yy>C||map[xx][yy]>=map[x][y])
continue;
result=max(result,DFS(xx,yy)+1);
}
DP[x][y]=result;
return result;
}
int main()
{
scanf("%d%d",&R,&C);
for(int i=1;i<=R;i++)
for(int j=1;j<=C;j++)
scanf("%d",&map[i][j]);
int result=1;
memset(DP,-1,sizeof(DP));
for(int i=1;i<=R;i++)
for(int j=1;j<=C;j++)
result=max(result,DFS(i,j));
printf("%d\n",result);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: